We are continuing to monitor for any further issues.
Posted Oct 01, 2021 - 06:36 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 01, 2021 - 05:39 PDT
Monitoring
If you do not see the email after your estimated wait time, please check your *junk* mail folder or *spam* folder, and click *Report Not Spam* if you see any Thunkable email.