Thunkable Platform Service Disruption

Incident Report for Thunkable Status Page

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:48 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 13:44 PDT

Update

Our platform is recovering from an earlier issue related to an ongoing incident with Google Cloud Platform. Some services may still experience degraded performance as systems stabilize.

You can follow the official GCP status here: https://status.cloud.google.com/

We’ll continue to monitor the situation and share updates as needed. Thank you for your continued patience.
Posted Jun 12, 2025 - 13:26 PDT

Monitoring

We are currently experiencing platform issues due to an ongoing incident with Google Cloud Platform. We're actively monitoring the situation and will provide updates as we learn more. Thank you for your patience.
Posted Jun 12, 2025 - 11:51 PDT
This incident affected: Thunkable Builder (Thunkable Designer, Server Infrastructure, Database), Build Servers (iOS Build Servers, Android Build Servers), and Live App (iOS Live App, Android Live App).