Thunkable Platform Service Disruption

Incident Report for Thunkable Status Page

Resolved

Cloudflare has resolved the issue.

We will continue to monitor this situation and provide updates if the issue re-surfaces.

Thank you for your patience.
Posted Nov 18, 2025 - 07:10 PST

Monitoring

We are currently experiencing platform issues due to an ongoing incident with Cloudflare Global Network.

You can follow the official Cloudflare Global Network status here: https://www.cloudflarestatus.com/

We’ll continue to monitor the situation and share updates as needed. Thank you for your continued patience.
Posted Nov 18, 2025 - 04:10 PST
This incident affected: Thunkable Builder (Thunkable Designer), Thunkable Website (Thunakble Website), and Mobile Web App Hosting.